Requirements

Mobile ID – Android

  • Android OS 2.1+.
  • Internet Connection is needed for Server Protected Identification – SPI

Mobile ID – iOS

  • Apple’s iPhone and iPad popular devices versions of Mobile ID are on the way and will be available soon.